メンバーメニュー

ようこそ、ゲストさん

トップ > カテゴリ一覧 > フリー/フリー 容量増加/フリー PHP+MySQLプラン > FTPでファイルをアップした後、接続ができない

質問

  • FTPでファイルをアップした後、接続ができない

    フリー

  • 本文:


    FileZillaというFTPソフトを使って
    サイトビルダーにあるファイルをアップしましたが、
    下記のような自分のサイトに接続できなくエラーメッセージが表示されてます。
    何かが問題があったのかがわかりません。
    http://gamejobinfo.starfree.jp/admin.php

    どこを直せば接続できるようになるのでしょうか?

  • 緊急度:緊急投稿者:vctrjpさん投稿時間:2018/02/26 13:51
質問に対する回答は締め切られました

回答 No.7007

  • この回答がベストアンサーです

  • 本文:

    TECHNOTE 7.5 - Freeware
    https://www.technote.co.kr/php/technote1/board.php?board=consult&command=skin_insert&exe=insert_down_shop

    設置環境
    PHP:4 *〜5.2.*
    (GD、iconv、Zend Optimizer)
    MySQL:4 *〜5 *


    最終バージョンでこれみたいですね。
    これから新規にこれを使ってサイトを作るというなら違うものを探したほうがいいと思います。
    どこかのサーバーで運用していたけれど閉鎖されるので移転、というのならまず行き先は見つからないんじゃないかと思います。
    仮に見つかっても、数年以内に大幅なサーバーのバージョンアップで使えなくなるか、閉鎖されてまた移転先を探すことになるんじゃないでしょうか。


    PHPのリリース日とサポート期限
    https://qiita.com/bezeklik/items/72d1ff8393f66673e2bc

  • 投稿者:kashaさん 投稿時間:2018/03/01 13:05

回答 No.6987

  • 本文:

    新しいphpでは、mysql_connectは、つかえないから、バージョンを落とすか、mysqli_やpdo系の関数を使う。

  • 投稿者:ジョバンニさん 投稿時間:2018/02/26 15:09
質問者からのコメント

ご回答ありがとうございます。
phpバージョンを下げてみたけど、うまくいかないです。

mysqli_やpdo系の関数を使う。
>初心者なので、調べてやってみます。

回答 No.6988

  • 本文:

    >どこを直せば接続できるようになるのでしょうか?
    その前に何をアップロードしたのかを書いた方がいいんじゃないでしょうか。


    gamejobinfo.starfree.jp にアクセスすると
    ハングル語の表示が出てきてリンク先に行くと
    仕様マニュアルみたいですけど

    >MySQL 3.8 ~ MySQL 5
    >PHP 4.3 ~ PHP 5.2*

    という化石みたいな環境用らしいので
    配布元で最近のサーバーに合ったものを配布していないかを探して入れなおしたほうがいいかもしれません。

    スターサーバーはデフォルトのPHPは7.0.*になっているので
    管理画面から5.1.6を選択すればひょっとしたらエラーが出なくなるかもしれないし、違うエラーが出るかもしれません。


    以下は該当するかどうかわかりませんが一応念のため

    https://www.netowl.jp/rule/starserver_server.php
    >第5章 [ 無料プランに関する特則 ]
    >第18条 利用申込
    >本サービスの利用者は、原則として日本に在住する個人もしくは日本に存在する法人に限ります。
    >また、各種申し込みおよび手続きにあたり日本国内のネットワークより本サービスにアクセスを行うものとします。

  • 投稿者:kashaさん 投稿時間:2018/02/26 15:59
質問者からのコメント

ご回答ありがとうございます。

・Technote7という韓国のビルダーです。
・phpのバージョンを5.*に変更してみましたが、それでも同じく接続できませんでした。
・第18条にはクリアです。

回答 No.6995

  • 本文:

    >初心者なので、調べてやってみます。

    一瞬見えていたエラーメッセージによれば、

    >>>
    本プログラムのPHPファイルの一部は符号化されています。
    エンコードされたphpファイルは、サーバのPHP環境でZend Optimizerがサポートされた時のみ正常に動作します。
    ところが、現在このサーバーのPHP環境では、ZendOptimizerが正常にサポートされていないと診断がされます。
    インストールの途中で、もはや次のステップに進み行かない現象が発生し、私ならZend Optimizerの問題だからサーバー管理者側に
    要請してZend Optimizerの問題を解決してください。
    正常な状態では、この内容は出力されません。
    <<<

    なので、サーバーが対応していないのかもね..

    一部文字化けして見えた部分は、「一部は符号化されて」の部分で、多分メーカーが意図的に暗号化していてわざと動かなくしている部分ではないですかね。

    相当に古いプログラムのようなので、メーカーに問い合わせたほうがいいのでは?

  • 投稿者:ジョバンニさん 投稿時間:2018/02/28 07:51

回答 No.7045

  • 本文:

    平素はネットオウルをご利用いただき誠にありがとうございます。
    ネットオウル運営チームです。

    本ご質問は一定期間新たな回答がなかったため
    運営チームで締め切らせていただきました。


    ■質問の締め切りについて

    Q&A掲示板はユーザー様同士の交流掲示板です。
    回答がもらえた場合、回答者へお礼コメントをしましょう。

    問題が解決した際にはベストアンサーを選び、
    質問を締め切ってください。


    ■再度のご質問について

    ご質問が未解決の場合、「ワンポイント!」を参考に、
    再度質問してみてください。

    【ワンポイント!】

     メールやFTPの設定がうまくいかない場合、
     ネットオウルIDやサーバーIDなどのお客様情報を公開しない範囲で、
     現在の設定内容を出来るだけ詳しく書いてみましょう。
     設定内容のミスを指摘してもらえるかもしれません。

     エラーが出てうまくいかない場合、
     エラーメッセージの内容を書いてみましょう。
     エラーメッセージにはエラー原因が詳しく書かれていることが多く、
     問題の解決につながる回答が得られるかもしれません。


    ■ベストアンサーについて

    ご質問の締め切りに際して、運営チームにて
    ベストアンサーを選んでおります。

     ※ベストアンサーの回答者様には通常と同様のポイントが
      付与されています。


    --ネットオウル運営チーム--

  • 投稿者:ネットオウル運営 投稿時間:2018/03/14 14:03