メンバーメニュー

ようこそ、ゲストさん

トップ > カテゴリ一覧 > ミニバード > 共有SSLについて

質問

  • 共有SSLについて
  • 本文:

    はじめまして、自分はwordpressをインストールして、CMSの勉強をしています。

    昨日、プラグインWordpress HTTPSを有効化して、forceを有効化してしまいました。
    管理画面に入れないので、共有sslを設定してみました。
    アドレスは、https://sis-illustjp.ssl-netowl.jp です。

    問題は、日が変わっても、次のメッセージが出ることです。
    "設定が反映されていないか、存在しないアドレスです。"
    アドレスバーには、https://sis.illust.jp に変化します。

    反映にまだ時間がかかるのか、何か根源的な問題があるのでしょうか?

    よろしくお願いします。

  • 緊急度:通常投稿者:kasamotoさん投稿時間:2016/09/27 06:19
質問に対する回答は締め切られました

回答 No.5224

  • この回答がベストアンサーです

  • 本文:

    問題は、大雑把に言って、2点。

    1a)
    http://sis.illust.jp/wp-admin/ を
    https://sis-illustjp.ssl-netowl.jp/wp-admin/ にリダイレクトしなくてはいけないところを、
    https://sis.illust.jp/wp-admin/
    のリダイレクトしている。

    1b)
    https://sis-illustjp.ssl-netowl.jp/wp-admin/ に直接アクセスしても、ログインフォームのurlが、"https://sis.illust.jp/wp-login.php" になっていて、https://sis-illustjp.ssl-netowl.jp/wp-login.php になっていない。

    2) 読み込んでいる .css ファイルの url が、http://sis.illust.jp/ でのアクセスになっているので、「部分的に http アクセスが混ざっている」ので、(ブラウザによっては)全体として httpsアクセスにならないの警告が出る(あるいはアクセスそのものができない)

    まあ、「プラグインWordpress HTTPS」ができそこないでなければ、
     http://sis.illust.jp/ の ssl版の url が、https://sis-illustjp.ssl-netowl.jp/ であることを設定する画面」がどこかにあるはずなので、それを設定する。
    wordpress が、css ファイルなどの内部リンク先を (標準では)相対パスでなく、絶対パスで作成するのは仕様なので、相対パスになるようにするか、httpsでアクセスされたときは、urlが https:///sis-illustjp.ssl-netowl.jp/ になるように手を加える。
    (「プラグインWordpress HTTPS」ができそこないでなければ、そのくらいは、自動でやってくれてもよさそうなものだけれど)

    http://o-way.net/wordpress-https-setting/ の説明を見る限りでは、,呂任そうですけどね。
    △蓮wordpressの site_urlの設定とか絡む話なので、「Wordpress HTTPS」でできているのかどうかは、よくわかりませんね。


    なお、https://sis.illust.jp/ でアクセスすると、"設定が反映されていないか、存在しないアドレスです。" となるのは、minibird の仕様です。待っていても変わりません。

  • 投稿者:ジョバンニさん 投稿時間:2016/09/27 07:18
質問者からのコメント

ジョバンニさん

なるほど、そうでしたか。ありがとうございます。
まずは、管理画面を復帰させました。

回答 No.5225

  • 本文:

    >昨日、プラグインWordpress HTTPSを有効化して、forceを有効化してしまいました。

    FTPで「Wordpress HTTPS」プラグインのフォルダを削除すると、とりあえずはログインできるようになるかと思います。



    >何か根源的な問題があるのでしょうか?

    「Wordpress HTTPS」プラグインの設定のSSL HOSTの設定欄に「https://sis-illustjp.ssl-netowl.jp 」を設定しないとダメな気はします。


  • 投稿者:k-tanさん 投稿時間:2016/09/27 09:01
質問者からのコメント

k-tanさん
はじめまして、簡潔に教えていただき、ありがとうございます。
ssl host欄を間違っていました。

回答 No.5301

  • 本文:

    平素はネットオウルをご利用いただき誠にありがとうございます。
    ネットオウル運営チームです。

    本ご質問は一定期間新たな回答がなかったため
    運営チームで締め切らせていただきました。


    ■質問の締め切りについて

    Q&A掲示板はユーザー様同士の交流掲示板です。
    回答がもらえた場合、回答者へお礼コメントをしましょう。

    問題が解決した際にはベストアンサーを選び、
    質問を締め切ってください。


    ■再度のご質問について

    ご質問が未解決の場合、「ワンポイント!」を参考に、
    再度質問してみてください。

    【ワンポイント!】

     メールやFTPの設定がうまくいかない場合、
     ネットオウルIDやサーバーIDなどのお客様情報を公開しない範囲で、
     現在の設定内容を出来るだけ詳しく書いてみましょう。
     設定内容のミスを指摘してもらえるかもしれません。

     エラーが出てうまくいかない場合、
     エラーメッセージの内容を書いてみましょう。
     エラーメッセージにはエラー原因が詳しく書かれていることが多く、
     問題の解決につながる回答が得られるかもしれません。


    ■ベストアンサーについて

    ご質問の締め切りに際して、運営チームにて
    ベストアンサーを選んでおります。

     ※ベストアンサーの回答者様には通常と同様のポイントが
      付与されています。


    --ネットオウル運営チーム--

  • 投稿者:ネットオウル運営 投稿時間:2016/10/12 10:55